Deprecated page

Taverna has now moved to the Apache Software Foundation. This page is provided for archival purposes only. For updated information, see Apache Taverna (incubating).

Quick start guide

Taverna is a powerful scientific workflow management application that allows designing and executing workflows.

Scientific workflows help tackle the problem of excessive complexity of in silico experimentation by helping scientists model what an experiment is set to achieve, while abstracting out how it will be executed.

This quick start guide will help you open, create and run a workflow. Before you start, you should download the Taverna Workbench.

You should also refer to the User Manual, which contains a more comprehensive documentation on how to use Taverna.

Opening an existing workflow

It is simple to open an existing workflow inside the Taverna Workbench.  If you already have a Taverna workflow, go to File ->Open Workflow and navigate to your workflow file (it should be in .t2flow format).

When you click OK, if the workflow loads correctly, the Workflow Diagram and Workflow Explorer panels are populated with the workflow defined in the file. There may be a short delay while Taverna contacts the network to get more information about the resources (services) the workflow uses – if the delay is a very long one followed by an error you probably need to check the configuration of your HTTP Proxy Preferences.

If you do not have an existing workflow, you can download and open one from myExperiment. For bioinformatics examples, go to myExperiment and search for the Pack entitled “Bioinformatics Workflow Examples“. From this pack, download the workflow entitled Blast_Align_and_Tree by selecting it and selecting the Download option “Download Workflow File/Package (T2FLOW)”. Alternatively, you can copy the link location from the Run section in the workflow entry page. If you go to File -> Open Workflow Location…. in the workbench, you can paste this link directly into the dialogue box.

To run the workflow, click the green ‘play’ button at the top of the workbench, or go to File -> Run workflow. In the pop-up workflow input box, add the first input (your email address), by selecting ‘set value‘ and typing it in the box. Change to the other input tab (sequence) at the top of the window and add a protein sequence in FASTA format in the same way. An example is given and will be automatically added when you click on ‘set value’, but you can add your own instead if you wish. To launch the workflow, click ‘Run workflow’ at the bottom of the input window.

For more general workflow examples, you can find and download workflows from the Taverna 2.x starter packs (see Taverna 2.4 starter pack for the current set).

You can additionally access the content of myExperiment directly from the Taverna Workbench by selecting the myExperiment Perspective at the top of the workbench. The Starter Pack tab in the myExperiment Perspective contains the current Taverna 2.x starter pack of workflows.

Creating a workflow

We will now create and run a very simple Taverna 2.x workflow to list some cities in a country. When you start the Workbench up, the default perspective you are presented with is the Design Perspective which is used for creating and editing workflows. To start creating a new workflow, choose New workflow from the File menu.

Adding a service into Taverna

Taverna 2.x does not, by default, “know” about a suitable service to perform the desired functionality. To add a new Web service click Import new services in the Service Panel and then WSDL service…. Enter the URL of the WSDL, in this casehttp://www.webservicex.com/globalweather.asmx?WSDLand click OK.

After a while, the service will become available in the Service Panel. If you filter the services by “globalweather” then you can see the two new services under “WSDL @ http://www.webservicex.com/globalweather.asmx?WSDL”.

Adding a service into the workflow

To add a service we have just imported in Taverna into the workflow, click on GetCitiesByCountry in the Service Panel and drag it into the Workflow Diagram or to the tree in the Workflow Explorer.

Creating the workflow inputs

The workflow needs to have an input, in this case the name of the country to query. You can create a new workflow input by right clicking in a blank area of the Workflow Diagram and select Insert -> Workflow input port. This will then ask you for a name for the input port, you can change this later but for now use “country”. Click OK and you should see your new input appear in the Workflow Diagram and Workflow Explorer.

Similarly, the workflow will need an output. Follow an equivalent process but this time clicking on Insert -> Workflow output port and using the name “cities” to create an output. Again, you should see the output appear in the two panels of the Workbench.

Splitting the WSDL inputs and outputs

For many services, you can connect their inputs and outputs directly. However, for WSDL services you may need to “split” the XML used to hold the input and output values. To do this, right-click on the service GetCitiesByCountry in the Workflow Diagram or Workflow Explorer and select Show details.

A description of the service will appear in the Details view of the Workflow Explorer. Scroll down and click both Add input XML splitter and Add output XML splitter, choosing “parameters” in both cases.

Connecting everything together

To link the input port, click on “country” and drag to the “GetCitiesByCountry_input”. A connection arrow will appear in the Workflow Diagram. If there had been several ports that you could have connected to, then the multiple options would have been offered to you. Alternatively, you may right-click the “GetCitiesByCountry_input” input port of the service and select Connect with output from… ->Workflow input ports and select the “country” workflow input port.

To connect from the “GetCitiesByCountry_output”, right-click on it and select Connect as input to… ->Workflow output ports and select the “cities” output port. Alternatively, you may start to draw a link (a green arrow will appear) from the “GetCitiesByCountry_output” output port of the service towards the workflow output port “cities”.

Running the workflow

You can now run the workflow you have just created.

Select Run workflow from the File menu. In the Workflow Inputs Dialog, as there is only one input port, you can click New value button.  Replace the string “Some input data goes here” by your chosen country name. After you have entered it, you can click Run workflow.

Taverna 2.x will automatically switch to the Results Perspective. The workflow run will be displayed in the Monitor View tabs (either as a graph showing progress or as a progress table). This panel shows you the progress of the workflow – running services are shown green and completed ones in grey. As the results are produced they are listed, for each output, in the Port Results View. After the workflow has run (indicated by GetCitiesByCountry turning grey), you will see a string “Value 1″ appear in the lower left panel. This is the identifier of the output result. If you click on this, you will see the output appear in the Rendered Result panel of the Port Results View.

Congratulations, you have created and run a workflow.

Closing the workflow

To close the current workflow, select Close workflow from the File menu.